Wasabi Cloud Storage London Outage

Incident Report for Magnetar IT

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 13:28 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 13:25 GMT

Investigating

Maintenance being carried out by Wasabi is impacting service availability.
Posted Mar 26, 2025 - 13:22 GMT